Issues accessing Microsoft 365 services

Incident Report for McMaster University

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 19:12 EST

Investigating

A networking issue in Canada that caused Microsoft 365 services to enter an unhealthy state. You may notice some services not working as expected. The service is continuing to recover and Microsoft is continuing to monitor.
https://status.cloud.microsoft/
Posted Mar 03, 2025 - 15:11 EST
This incident affected: Microsoft Office 365 (Email, Teams, Onedrive, SharePoint).