Mosaic - Unavailable

Incident Report for McMaster University

Resolved

The team has identified and resolved the issue.
Posted Aug 30, 2025 - 09:38 EDT

Investigating

We are currently investigating the issue and will look to resolve as soon as possible.
Posted Aug 30, 2025 - 07:52 EDT
This incident affected: Mosaic (Campus).