Mosaic Issues

Incident Report for McMaster University

Resolved

Service has been restored and Mosaic is operating normally. Thank you for your patience.
Posted Aug 24, 2026 - 16:22 EDT

Update

We are continuing to investigate the issue affecting the Mosaic Careers page. We are also aware of reports of slowness and intermittent performance issues in other areas of Mosaic. Our team is working to restore full service and will provide updates as more information becomes available.
Posted Aug 24, 2026 - 09:39 EDT

Investigating

The Mosaic Careers page is currently unavailable. Our team is aware of the issue and is working to restore the service. We apologize for the inconvenience and will provide updates as more information becomes available.
Posted Aug 23, 2026 - 17:36 EDT
This incident affected: Mosaic (Human Resources).