MacDrive

Incident Report for McMaster University

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 16:08 EDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 15:23 EDT

Investigating

We are currently investigating an issue with MacDrive affecting logins.
Posted Apr 24, 2025 - 14:42 EDT
This incident affected: MacDrive.