Issues logging into Mosaic

Incident Report for McMaster University

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 14:42 EDT

Investigating

Some users are reporting issues logging into Mosaic. We are currently investigating the issue.
Posted Apr 13, 2026 - 14:16 EDT
This incident affected: Mosaic (Campus, Finance, Human Resources).