Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 21, 2025 - 07:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 11, 2025 - 20:50 EST
Scheduled
Please be advised that University Technology Services (UTS) has scheduled maintenance in the UTS-managed Data Centres on Sunday, December 21, between 7:00 a.m. and 12:00 noon. As part of this work, end-of-life equipment will be removed, resulting in brief service interruptions (about one to two minutes) for systems hosted in the UTS virtual server environment.
All other systems hosted in the UTS managed Data Centres will not be impacted by this change.
Any longer, unanticipated interruptions related to this work will be posted on the McMaster IT Services Status Page.
This work is part of our ongoing efforts to improve service reliability and ensure that McMaster’s Data Centre environment remains secure and up to date.