System Slowness
Incident Report for McMaster University
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 10:09 EDT
Investigating
There are systems on campus that are slow in loading and accessing (eg. Mosaic, MacIAM, Jira) The team is investigating
Posted Apr 16, 2024 - 09:45 EDT