Exchange Online Service Degradation – Microsoft Incident

Incident Report for McMaster University

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 08:56 EDT

Investigating

Microsoft continues to investigate a service-wide issue affecting Exchange Online. Some users in Canada may be unable to access their mailboxes or send email messages using Outlook on the web or desktop. This is not specific to McMaster.
Posted Sep 25, 2025 - 14:48 EDT
This incident affected: Microsoft Office 365 (Email).