Degraded - Mosaic

Incident Report for McMaster University

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 12:32 EST

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 08:47 EST

Investigating

Some individuals are unable to log into Mosaic. The team is investigating and will update as soon as possible.

We appreciate your patience and support as we work to resolve this issue.
Posted Nov 24, 2025 - 08:46 EST
This incident affected: Mosaic (Campus).