Potential Email Delivery Delays

Incident Report for McMaster University

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 08:32 EDT

Identified

We are currently aware of an issue affecting bulk email delivery:
- Some emails sent through EDLs (Electronic Distribution Lists) and Mailman mailing lists may be delayed, blocked, or rejected by certain external recipients.
- Email sent directly through Microsoft 365 (Outlook/Exchange Online) is not affected.
- This issue impacts only one of two legacy email gateways, so not all email traffic is affected.
- If an email is rejected, senders may receive a bounce-back notification.

Status: Our technical teams have identified the issue and are working to resolve. Normal service is expected to resume within approximately 24 hours.

We apologize for any inconvenience and will provide updates as they become available.
Posted Jul 20, 2026 - 13:11 EDT
This incident affected: Other Campus Wide Systems (EDL).