We are continuing to investigate the issue affecting user logins to Mosaic. Our teams remain actively engaged in identifying the root cause and working to restore service as quickly as possible.
We will provide further updates as more information becomes available. Thank you for your continued patience.
Posted Jun 12, 2025 - 12:45 EDT
Update
We are continuing to investigate the issue preventing users from logging into Mosaic. Our teams are actively working to identify the root cause and restore service as quickly as possible.
Further updates will be provided as new information becomes available. Thank you for your patience.
Posted Jun 12, 2025 - 09:33 EDT
Investigating
We are investigating issues with logging into Mosaic. Teams are working to resolve and will update as soon as possible.
We appreciate your patience and support as we work to resolve this issue.
Posted Jun 11, 2025 - 11:05 EDT
This incident affects: Mosaic (Campus, Finance, Human Resources, Hyperion).