Microsoft 365 Service Degradation

Incident Report for McMaster University

Resolved

This incident has been resolved. Microsoft updated that the affected infrastructure has returned to a healthy state and is operating as expected. They are continuing to monitor the remediation actions taken and make any necessary adjustments to maintain stability.
Posted Jan 23, 2026 - 08:19 EST

Monitoring

While Microsoft has restored affected infrastructure to a healthy state, it may take time to update services. Please try again later. https://status.cloud.microsoft/
Posted Jan 22, 2026 - 16:55 EST

Investigating

Users may be seeing degraded service functionality or be unable to access multiple Microsoft 365 services.
Posted Jan 22, 2026 - 16:40 EST
This incident affected: Microsoft Office 365 (Email, Teams, Onedrive).