Outage - Staff and Faculty Directory
Incident Report for McMaster University
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 09:21 EDT
Investigating
Staff and Faculty Directory is currently unavailable. Teams are investigating and will update as soon as possible.

We appreciate your patience and support as we work to resolve this issue.
Posted Mar 19, 2024 - 08:56 EDT
This incident affected: Staff and Faculty Directory.