Outlook Web Attachments
Incident Report for McMaster University
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 09:33 EDT
Investigating
Users may be intermittently unable to download attachments or view embedded images in Outlook on the web. Current temporary work around is to clear the cache in your browser. Microsoft is working on the issue.
Posted Apr 11, 2024 - 13:54 EDT
This incident affected: Microsoft Office 365 (Email).