Microsoft Service Disruption

Incident Report for McMaster University

Resolved

The issues affecting Microsoft services and applications appear to have been resolved.

If you continue to experience any issues, please contact the UTS Service Desk for assistance. Thank you for your patience and understanding while this was being addressed.
Posted Oct 30, 2025 - 14:13 EDT

Monitoring

We are aware that members of our university community may be experiencing issues accessing various Microsoft applications and services. This disruption appears to be part of a broader Microsoft Azure outage currently affecting users across North America and beyond.

Microsoft has acknowledged the issue and is actively working to restore services. They have initiated a rollback to a previous stable configuration and there are early signs of recovery. Microsoft estimates that "full mitigation" should arrive "within the next four hours."

We will continue to monitor the situation and provide updates as more information becomes available. Thank you for your patience and understanding.
Posted Oct 29, 2025 - 15:47 EDT
This incident affected: Microsoft Office 365 (Email, Teams, Onedrive, SharePoint).