Email Delays
Incident Report for McMaster University
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 15:56 EDT
Investigating
Microsoft is reporting that some inbound and outbound messages may be intermittently delayed when sending. They are investigating the issue.
Posted Apr 17, 2024 - 12:14 EDT
This incident affected: Microsoft Office 365 (Email).