Mosaic - degraded performance

Incident Report for McMaster University

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 08:50 EDT

Investigating

We are experiencing issues with Mosaic - slowness and log in issues. Teams are investigating and will update as soon as possible.
Posted Oct 28, 2025 - 15:33 EDT
This incident affected: Mosaic (Campus, Finance, Human Resources, Hyperion).