JIRA Service Management Update

Scheduled for Nov 3, 18:00 - 22:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 28, 2025 - 18:11 EDT

Scheduled

Please note, we will be updating the Jira Service Management software from Version 10.3.10 to 10.3.12.
The Process will begin at 6pm and the application will not be available.
We apologies for any inconvenience.
Posted Oct 28, 2025 - 18:09 EDT
This scheduled maintenance affects: JIRA (JIRA Service Desk).