Faculty of Science Websites Unavailable

Incident Report for McMaster University

Resolved

The issue has been resolved and the websites are fully functional. Thanks for your patience.
Posted Jun 05, 2026 - 16:16 EDT

Investigating

Some Faculty of Science websites are currently unavailable. Our team is aware of the issue and is actively working to restore service as quickly as possible. We will provide updates as more information becomes available.
Posted Jun 04, 2026 - 13:49 EDT
This incident affected: Other Campus Wide Systems (McMaster University Websites).