Exchange Online Issue

Incident Report for McMaster University

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 19:09 EDT

Update

Microsoft has restored service as of 6:15 pm (June 1).
Posted Jun 01, 2026 - 19:04 EDT

Investigating

Some users may be unable to access Exchange online using multiple connection methods - Microsoft will provide the next update Monday June 1st 5pm
Posted Jun 01, 2026 - 15:58 EDT
This incident affected: Microsoft Office 365 (Email).